'Your Mac needs to be updated to improve compatibility' Scam

'Your Mac needs to be updated to improve compatibility' Scam Description

While the 'Your Mac needs to be updated to improve compatibility' message is a perfectly legitimate warning prompt that some users may encounter on their Mac computers, it also has been co-opted by dubious, counterfeit websites. The alert may be displayed as part of the misleading and deceptive scenario that is run by the particular misleading page. The goal of the different suspicious websites also may vary - some may focus on obtaining particular login credentials from the visitors while others could be promoting a sponsored PUP (Potentially Unwanted Program).

The message accompanying the 'Your Mac needs to be updated to improve compatibility' prompt might be adjusted accordingly. One potential scenario runs as follows:

'Your Mac needs to be updated to improve compatibility
Enter your password to allow this.
Username:
Password:
Cancel / OK
'

Others could focus on pushing the user towards clicking a 'Download' or 'Install' button for a program that would allegedly fix the problem. Instead, users are getting a browser hijacker or an adware app on their Mac. 

In addition, the fact that the user has landed on a deceiving page is in itself a potential sign that a PUP has already managed to sneak itself onto the computer system. PUPs are not considered a direct threat but their activity can represent a significant increase in security risks. Adware can generate intrusive advertising materials that redirect to unsafe sites while browser hijackers can take over the web browser and force it to open dubious search engines that track the user's browsing activity.