सफारी में 'अवरुद्ध प्लग-इन' को कैसे ठीक करें

वर्षों से, प्लग-इन वेब ब्राउज़र जैसे कार्यक्रमों की कार्यक्षमता का विस्तार करने के उद्देश्य से सहायक घटक रहे हैं। वे विभिन्न सामग्री प्रकारों के समर्थन और ठीक से प्रदर्शित होने के लिए आवश्यक थे। हालांकि, अधिकांश प्लग-इन तृतीय पक्षों द्वारा जारी किए गए हैं और ऐतिहासिक रूप से सिस्टम कमजोरियों और सुरक्षा मुद्दों से जुड़े हुए हैं। जैसे, कई ब्राउज़रों ने प्लग-इन की आवश्यकता को मूल रूप से उस कार्यक्षमता को एकीकृत करके दूर करना शुरू कर दिया है।

फिर भी, उपयोगकर्ताओं को सफारी में एक 'अवरुद्ध प्लग-इन' त्रुटि संदेश का सामना करना पड़ सकता है। आमतौर पर, संदेश इंगित करता है कि सिस्टम ने एक विशिष्ट प्लग-इन को निष्पादित करने से रोक दिया है। ज्यादातर मामलों में, ब्राउज़र और प्लग-इन के संस्करण के बीच एक असंगति समस्या का पता चला हो सकता है। आप सफारी ब्राउज़र या खराब प्लग-इन को अपडेट करने का प्रयास कर सकते हैं, जिसके आधार पर अपडेट उपलब्ध है। आप इसे ब्राउज़र में मैन्युअल रूप से सक्षम करने का भी प्रयास कर सकते हैं:

  1. सफारी मेनू का चयन करें।
  2. 'वरीयताएँ' चुनें।
  3. 'वेबसाइट' टैब चुनें।
  4. इंस्टॉल किए गए प्लग-इन की सूची पर जाएं, जिसे आप चाहते हैं उसे चुनें और इसे सक्षम करने के लिए इसके संबंधित बॉक्स को चेक करें।

'अवरुद्ध प्लग-इन' खतरनाक कार्रवाइयों का संकेत दे सकता है

'अवरुद्ध प्लग-इन' की उपस्थिति हमेशा एक सौम्य समस्या का संकेत नहीं हो सकती है। उपयोगकर्ता को बरगलाने के प्रयास में, दूषित एप्लिकेशन या ब्राउज़र एक्सटेंशन द्वारा भी इसका फायदा उठाया जा सकता है। यदि मैक पर ऐसे एप्लिकेशन मौजूद हैं, तो वे नकली 'अवरुद्ध प्लग-इन' त्रुटियां दिखा सकते हैं जो उपयोगकर्ता को 'सुविधाजनक' प्रदान किए गए बटन पर क्लिक करके एक विशिष्ट प्लग-इन को अपडेट करने का आग्रह करती हैं। ऐसा करने से एक संदिग्ध या असुरक्षित वेबसाइट पर रीडायरेक्ट ट्रिगर हो सकता है। उपयोगकर्ता ऑनलाइन रणनीति, नकली उपहार, फ़िशिंग पेज या पीयूपी (संभावित रूप से अवांछित कार्यक्रम) को बढ़ावा देने वाले डोमेन पर उतर सकते हैं। यह योजना गंभीर मैलवेयर खतरों को भी जन्म दे सकती है। ऐसे नकारात्मक परिणामों की संभावना को कम करने के लिए, यह अनुशंसा की जाती है कि आप नियमित रूप से एक पेशेवर सुरक्षा समाधान के साथ अपने मैक का पूरी तरह से स्कैन करें।