如何修复 Safari 中的“被阻止的插件”

多年来,插件一直是有用的组件,旨在扩展 Web 浏览器等程序的功能。它们对于支持和正确显示各种内容类型至关重要。但是,大多数插件已由第三方发布,并且在历史上与系统漏洞和安全问题相关联。因此,许多浏览器已经开始通过本地集成许多插件功能来摆脱对插件的需求。

尽管如此,用户可能会在 Safari 中遇到“阻止插件”错误消息。通常,该消息表明系统已停止执行特定插件。在大多数情况下,可能已检测到浏览器与插件版本之间的不兼容问题。您可以尝试更新 Safari 浏览器或出现故障的插件,具体取决于哪个有可用更新。您也可以尝试在浏览器中手动启用它:

  1. 选择 Safari 菜单。
  2. 选择“首选项”。
  3. 选择“网站”选项卡。
  4. 转到已安装插件列表,选择您想要的插件,然后选中其对应的框以启用它。

“被阻止的插件”可能表明存在威胁行为

'Blocked Plug-in' 的存在可能并不总是一个良性问题的信号。它也可能被损坏的应用程序或浏览器扩展程序利用,试图欺骗用户。如果 Mac 上存在此类应用程序,它们可能会显示虚假的“阻止插件”错误,促使用户通过单击“方便”提供的按钮来更新特定插件。这样做可能会触发重定向到有问题或不安全的网站。用户可能会使用在线策略、虚假赠品、网络钓鱼页面或宣传 PUP(潜在有害程序)的域。该计划还可能导致严重的恶意软件威胁。为了减少出现此类负面结果的可能性,建议定期使用专业的安全解决方案对您的 Mac 进行彻底扫描。